Dynamic EU communities are currently unavailable
Incident Report for Dynamic Signal
Postmortem

Summary: 

From approximately 11:10 am - 11:35 am GMT, Wednesday April 10th, EU hosted communities on the Dynamic Signal Platform experienced a disruption in service caused by an exhaustion of local storage space.  

Impact:

Users accessing the Member app would have encountered a Technical Difficulties page during this time.

Mitigation: 

The issue was determined to be an exhaustion of local storage space on an affected Web Server and was quickly corrected to restore service. Also during this period of time the issue would have been mitigated upon a refresh of the Member app page as the communities would have been redirected to an available Web Server without the storage issue.   

Root Cause Analysis: 

The issue was determined to be rapid storage growth of local storage space on an affected Web Server. This caused those users who initially connected to the affected Web Server which hosts the Member app to be temporarily unavailable.

Recurrence Prevention: 

To prevent a future recurrence, the below actions have been implemented:

  1. Log automation removal has been optimized to make sure our production operating limits are tolerant of surges and organic growth over time. 
  2. In the event of an unexpected storage increase, alerting has been improved to lower the threshold so it will be triggered as ‘Disaster’ when it gets to a certain percentage and intervention will be taken sooner before a disruption of service occurs.
Posted Apr 25, 2024 - 08:27 PDT

Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 06:51 PDT
Update
The issue was determined to be an exhaustion of local storage space, and was quickly corrected to restore service. A Post Mortem will be provided to advise on preventative measures that have been implemented.
Posted Apr 15, 2024 - 06:51 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 10, 2024 - 04:16 PDT
Update
We are continuing to investigate this issue.
Posted Apr 10, 2024 - 03:42 PDT
Update
We are seeing the Member app on EU being available again - investigating root cause.
Posted Apr 10, 2024 - 03:41 PDT
Investigating
We are currently investigating an issue whereby EU communities are unavailable for the Member app. A 'Technical Difficulties' page is currently being displayed - updates to follow.
Posted Apr 10, 2024 - 03:24 PDT
This incident affected: Products (Member App, iOS App, Android App) and Platforms (EU Firstup Dynamic Platform).