Video Uploads Failing with "There was a network error..."

Incident Report for Dynamic Signal

Resolved

This issue is resolved, with no further reports of video upload failures, and confirmation the implemented fix is working.
Posted Oct 27, 2025 - 10:15 PDT

Monitoring

The cause of the issue where video uploads are failing with an error message has been identified and a fix implemented.
Posted Oct 24, 2025 - 14:01 PDT

Update

Engineering continues work to identify the cause of the issue preventing video uploads in the Manager app. We'll share another update in an hour.
Posted Oct 24, 2025 - 13:20 PDT

Update

We are continuing to investigate this issue.
Posted Oct 24, 2025 - 12:25 PDT

Investigating

We are currently investigating an issue where video uploads are failing with an error message, "There was a network error..."

We will provide you with an update within 1 hour.
Posted Oct 24, 2025 - 11:49 PDT
This incident affected: Products (Manager App) and Platforms (US Firstup Dynamic Platform, EU Firstup Dynamic Platform).