No image being shared when some customers are attempting to share natively to facebook
Incident Report for Dynamic Signal
Postmortem

Summary: 

On Wednesday, June 24th, 2024, starting at around 05:29 AM PST (14:29 UTC), we received reports of incorrect display of links on posts shared to Facebook. We determined the root cause to be a newly imposed or enforced API request volume restriction by our URL shortener Bit.ly. This led to failures in link shortening and displaying posts on social media platforms.

Impact: 

The scope of this incident primarily affected users who did not have a custom bit.ly configuration. The incident caused sharing links to display incorrectly on Facebook, resulting in posts that did not show the community name, post title, or images properly. 

Mitigation: 

The issue was temporarily mitigated on July 1st when the API monthly quota was reset however the API limit soon exceeded again.

Root Cause:

An exceeded API quota caused disruptions in our URL shortening service, leading to incorrect display of links on posts shared to Facebook. The root cause was traced to API limits recently imposed by our URL shortener Bit.ly, with whom Firstup Dynamic once had a legacy account providing unlimited links and API requests. This led to failures in link shortening and displaying posts on social media platforms. The incident was also prolonged by a company wide bit.ly holiday which delayed the discussion/creation of a new custom account to implement a quota allowance which would match our needs.

Recurrence Prevention: 

Enhanced Monitoring and Alerts: The new Custom API account allows the development of more robust monitoring and alerting mechanisms for API usage quotas to prevent exceeding limits. This includes alerting for when the API usage approaches critical thresholds. 

Exploration of Alternative Solutions: Continuously explore and evaluate alternative solutions to prevent over-reliance on a single provider. This includes investigating other URL shortener services and developing abstractions so that we may keep our options open.

Posted Jul 22, 2024 - 01:43 PDT

Resolved
Full sharing functionality has been restored for Facebook Sharing at approx 12:48 UTC today, images and all the appropriate information should now be displayed on Posts for those customers who do not have a custom bit.ly configuration.
Posted Jul 15, 2024 - 07:28 PDT
Update
We have a solution identified to restore Facebook Sharing, this will be implemented after all the appropriate checks have taken place. Next update to follow will confirm when this has been implemented.
Posted Jul 12, 2024 - 04:44 PDT
Update
We are continuing to work with the Vendor to resolve this issue with Facebook sharing for those customers who do not have a custom bit.ly configuration. The issue is related to the number of requests being sent through the API, we should have an update soon.
Posted Jul 10, 2024 - 06:45 PDT
Identified
We have identified an issue whereby when some customers are attempting to share natively to facebook, no image is being shared in the post. This is isolated to Facebook and will impact some customers who do not have a custom bit.ly configuration.
Posted Jul 02, 2024 - 05:48 PDT
This incident affected: Social Integrations (Facebook) and Platforms (US Firstup Dynamic Platform, EU Firstup Dynamic Platform).